[Fix] - Visual Studio 2015 SSIS Development Backward Compatibility develop 2008 2012 2014 packages

Wikitechy | 3082 Views | visual studio | 09 Jun 2016

 

Error :

  •  Visual Studio 2015 SSIS Development Backward Compatibility develop 2008 2012 2014 packages

Scenario :

  • When I try to determine if Visual Studio 2015 (VS2015) Ultimate or any other version VS2015 will allow for SSIS packages for 2008, 2012, 2014 environments.

Fixes:

Fix1 :

  • Check the SQL version based on the version we deploy the SSIS Package for example 
  • Use the SQL Server 2008 version of Business Intelligence Development Studio to develop and maintain packages that are based on SQL Server 2008 Integration Services (SSIS)
  • Use the SQL Server 2012 version of SQL Server Data Tools (SSDT-BI for VS 2012) to develop and maintain packages that are based on SQL Server 2012 Integration Services (SSIS).
  • Use the SQL Server 2014 version of SQL Server Data Tools (SSDT-BI for VS 2013) to develop and maintain packages that are based on SQL Server 2014 Integration Services (SSIS).

 Fix2 :

  • It depends on SQL Version that we have installed and  will be able to develop only latest version that is 2014.
  • Once after we create a new package, version of it is stamps in .dtsx code and we can open or deploy this package to lower versions and it gives an error saying package was developed in higher version.


Fixes are applicable to the following versions of Visual studio :

  • Visual Studio 2015 - SSIS Development
  • SSIS Development in VS2015 
  • SSIS visual studio 2013
  • Access denied error in SQL server

Related Error Tags :

  • Version compatibility in VS
  • Backward Compatibility in VS
  • Create SSIS package in visual studio 2013 




Workshop

Bug Bounty
IOT Hackathon
Webinar

Join our Community

Advertise